Back to overview
Degraded
Partial Purchase Funnel Issues
Jul 29, 2022 at 12:43pm UTC
Resolved
Jul 29, 2022 at 01:27pm UTC
Purchase funnel issues now resolved
Affected services
Created
Jul 29, 2022 at 12:43pm UTC
Some customers might be experiencing issues completing a purchase through the main bundle purchasing funnel. This is under investigation
Affected services